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2 Fulcrum User Interface 

Presentation Outline 

•  Fulcrum Mission Statement 
•  Fulcrum Component Overview 

•  Fulcrum Input Editor 

•  Fulcrum Data Plotting 

•  Fulcrum Geometry Visualization 
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Fulcrum Mission Statement 

Provide a cross-platform graphical user interface (GUI) 
designed to facilitate problem creation, modification, 
navigation, validation, and visualization, as well as output 
and data file interaction as needed by new and experienced 
users. 
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Fulcrum Component Overview 



5 Fulcrum User Interface 

Fulcrum Document Navigation 

•  Hierarchical Listing of Document  
–  Quick Navigation to input component 
–  Plot creation 

•  Open Associated Files 
–  Lists files with matching extension-less filename 
–  streamlines opening associated files 

•  Filter  
–  Regular expression based item filtering 

•  Dockable 
–  Dock to main Fulcrum application 
–  Float in separate window 
–  Hide completely 
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Fulcrum Input Editor 
•  Syntax Highlighting  
•  Top Level Quick Navigation 
•  Cursor Context 
•  Preserves User Input Format 

•  Current Input Block Highlight  
•  Input Autocompletion 
•  Input Validation 
•  Customizable Input Execution 
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Fulcrum Plot Data 
•  Supports Most Major SCALE Data Formats •  Export to Image (supports svg) 
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Fulcrum General Output Result Plots 
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Fulcrum Geometry Visualization 
•  Interactive Geometry Visualization •  Support for Most Mesh Data* 

*Currently Support: 3dmap, Mesh Importance Map, Mesh Source Map, and Denovo Flux File 
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Summary 
•  Input editor facilitates problem creation, modification, 

navigation, validation, execution and output file viewing in a 
consistent, platform independent manner. 

•  Data plotting facilitates a fast, interactive means of 
interrogating input and output data. 
–  Supports most SCALE data formats. 

•  Geometry viewer facilitates a fast, interactive means of 
interrogating SCALE Geometry. 
–  Supports KENO and NEWT (non-polygon rendering).  

•  Fulcrum provides a modular workspace with splitting and 
drag-and-drop configurable layout.  

•  Questions? 
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Presentation Outline 
•  Fulcrum Input Editor Components 

•  Text Editor Settings 

•  Syntax Highlighting  

•  Document Quick Navigation 

•  Cursor Context 

•  Input Block Start and End Highlighting  

•  Input Autocompletion 

•  Input Validation 

•  Input Execution 

•  Output File Viewing 

•  Miscellaneous Features  

•  Future Features 
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Fulcrum Input Editor Components 
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Text Editor Settings 
•  Change font attributes 
•  Change syntax color by 

category 

•  Change current line highlight 

•  Modify recognized input file 
extensions 
–  Add a ‘.i’ extension 

•  Update default input editor 
close behavior 
–  When closing a tab, should the 

document also be closed if the 
closed tab is the last document 
tab.  

•  Accessed via File>Settings 
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Syntax Highlights 
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Document Quick Navigation   

•  Provides document 
outline. 

•  Quickly navigate to 
section from input editor 
drop-down or navigation 
tree. 

•  Places text cursor at 
start of input block. 
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Cursor Context 
•  Fulcrum uses cursor position to 

determine cursor context, line, 
column, and highlighting. 

•  Cursor context provides a file 
directory-style listing of the input 
component at cursor position. 
–  Helpful for identifying position-

dependent input components. 
–  Helpful for advanced SCALE 

features like Sampler model 
perturbations. 

•  Cursor line highlights provide fast 
cursor acquisition via bold-faced 
line number and highlighted line 
visual indicators. 

•  Cursor line and column entry 
fields provide quick navigation 

–  Useful for entering line and column 
numbers included in job execution 
failure messages.  

–  Accessible via clicking Line, Col text. 
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Input Block Start and  
End Highlighting 
•  Helps new users identify 

sections of input. 

•  Re-enforces SCALE’s Read 
Block construct. 

•  More effectively 
communicates Record 
Blocks which could have 
user-specified beginning. 

•  Assists users in identifying 
new input component 
sections, such as the 
Component and Array 
Blocks used in Origen and 
Origami input. 
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Input Autocompletion Overview 
Input Autocompletion provides the user a jump start in input creation and 
editing. Autocompletion uses the cursor’s context within the input to 
determine what input components are available and can be inserted. The 
types of autocompletion are as follows: 

•   Static input component insertion.  
–  Inserts a boilerplate piece of input requiring the user to update fields with 

appropriate values. 
–  Provides complete component incorporating component order, etc. 

•  Configurable input component insertion. 
–  Uses a popup window to capture component values and substitutes these 

values into a template creating and inserting a complete piece of input 
(potentially an entire input). 

•  Input value substitution. Uses cursor context to provide a list of legal 
attribute values. 
–   Convenient for selecting parameter values from a list (htm=yes or no). 
–   Helpful for substituting identifiers needed from other input components 

(available mixtures, region ids etc). 
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Input Autocompletion :  
Static Text 
•  Inserts default values. Requires user to update values as needed. 

Access Autocomplete via 
* CTRL+SPACE Keys, or, 
* Edit…>Autocomplete 
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Input Autocompletion :  
Static Text 

•  Static text insertion allows new and 
experienced users to quickly select 
and generate input that has order 
dependent components 

•  Standard Composition Records 
require a sequence of unlabeled 
components (mixture, volume 
fraction, temperature, etc).  

•  The requirement for the user to 
recall the correct order of entry is 
significantly reduced. 

•  Cursor context facilitates the user in 
identifying the inserted components 
needing to be changed. 

•  Greatly assists the user in the 
worst of order-dependent, 
unlabeled input entry. 

Access Autocomplete via 
* CTRL+SPACE Keys, or, 
* Edit…>Autocomplete 
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Input Autocompletion :  
Static Text 

•  Static text autocompetion also 
facilitates abbreviated input to 
include the component’s 
description allowing users to 
discover and/or more quickly recall 
the necessary input components 
for their analysis. 

•  Cursor context allows the 
autocompletion popup to show 
what is legal and has not already 
been specified.  

Access Autocomplete via 
* CTRL+SPACE Keys, or, 
* Edit…>Autocomplete 



23 Fulcrum User Interface 

Input Autocompletion : 
Configurable Text 

Access Autocomplete via 
* CTRL+SPACE Keys, or, 
* Edit…>Autocomplete 

•  Allows user to configure values prior to inserting into input. 
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Input Autocompletion : 
Configurable Text 
•  Configurable autocompletion allows 

entire input creation. 

•  Results preview facilitates learning 
input syntax. 

•  Attributes can be labeled even 
when the actual input attribute may 
not have a label. 

•  Attributes can have a drop-down 
listing the available or common 
values to specify. 

Access Autocomplete via 
* CTRL+SPACE Keys, or, 
* Edit…>Autocomplete 
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Input Autocompletion :  
Value Substitution 

•  When autocompletion is 
requested on an existing 
value that is either a member 
of a set of predefined or 
existing input component 
values/identifiers, an 
autocomplete popup is 
presented listing the available 
values to substitute. 

•  Helps user quickly remember/
learn what is legal/available. 

Access Autocomplete via 
* CTRL+SPACE Keys, or, 
* Edit…>Autocomplete 
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Input Validation Overview 
•  SCALE validation messages consist of parse and validation 

errors along with the input line and column. 
–  Clicking the message will quick navigate to the location in the input 

editor 

•  SCALE parse errors prevent the further processing of input 
and are hard errors in that the interpretation of the input is 
incomplete. 
–  Parse errors typically involve the input that guides the input parser. 

E.g., number of element-weight-percent pairs not matching actual 
number provided in the input.  

•  SCALE validation uses over 20 rules to provide immediate 
validation. These include value ranges, value uniqueness – is 
it unique in an input context, value existence – does the value 
exist in an input context, value enumeration – is the value a 
member of a list of values.  
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Input Validation Overview 
•  Parse errors cascade into other parse errors as the input parser attempts to 

find legitimate input. 

•  Parse errors often cause the input parser to terminate early preventing the 
entire input from being validated.  
–  Example below has wtpt element count (line 27) specified as 3, but only 

has 2 (8000,7000) specified causing a parse error and cascade. 
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Input Validation : Required Input 
•  Required input should minimally occur once in the input. 
•  When required input is missing autocompletion can quickly 

generate the missing blocks. 
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Input Validation :  
Value Errors 
Value constraint errors can 
be hard to find. Input 
validation provides 
immediate feedback on 
the following. 

•  Simple value ranges  
–  E.g., 0.0 < x <= 100  

•  More complex 
–  Expected value 

sums 
–  Expected value 

function (increasing, 
decreasing, etc.) 

–  Component 
relationship 
•  E.g., X > Y 
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Input Validation :  
Reference Errors 
Using component 
identifiers can lead to 
duplicate or missing 
identifiers.  

•  Checks if the 
component’s identifier 
is unique in the 
required input 
contexts. 
–  Ensure all geometry 

regions have unique 
identifiers. 

•  Check if the 
component identifier 
references an existing 
component 
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Input Execution Overview 
•  Execution is preconfigured to execute the SCALE included 

with Fulcrum. 

•  Execution of other applications (e.g., prior SCALE release) 
can be setup. 

•  Only local execution (no cluster or queue support, yet).  

•  Execution can be in the background. 
–  Allows closing Fulcrum without cancelling/terminating the execution. 

•  Input listing, mixing table, alias expansion, and volume 
calculation [prototype] are available via quick execution 
buttons. 

•  Messages from executions are stored in time stamped tabs. 
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•  Add new 
•  Clone existing 

•  Remove existing 

•  Modify existing 

•  Show executable 
help 

•  Provide additional 
arguments 

Input Execution : Customized Configurations 
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Input Execution : 
Running Jobs 
•  Run launches the selected configuration 

(SCALE 6.2). 

•  For Run a time-stamped Messages Tab 
is added with application messages 
panel. 

•  Alternatives are conveniently available 
via the Run drop-down. 

–  Run in background launches the job but with 
a terminal instead of a messages tab.  

–  Expand aliases unrolls aliased input 
(TRITON). 

–  Input listing provides directory-like input 
listing useful for Sampler model perturbation. 

–  Mixing table lists the atomic number 
densities (atoms/b-cm) per nuclide per 
mixture. 

–  Calculate volumes (prototype) runs a user-
specified number of rays per geometry axis 
and accumulates media volumes. The 
complete input with media ‘vol’ cards is 
echoed in the message tab. 
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Output File Viewing 
•  Easy to access from 

the Input file’s list of 
associated files popup 
context menu. 

•  No intelligent outline, 
yet. 

•  Output file Can be 
drag-n-dropped onto 
Fulcrum from a file 
browser (as can any 
SCALE file with an 
extension, *.inp,*.out, 
etc.). 
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Miscellaneous Features 
•  Column select/edit  

–  via ALT+left click+mouse drag key and mouse combo 
•  Go to definition – allows quick navigation to input components 

definition via a right click popup context menu. 
–  E.g., anywhere an identifier is used to reference another input 

component. 
•  Math evaluator 

–  Ability to evaluate selected text as a math expression – replaces 
selection with expression’s result. 

•  Comment toggle  
–  Ability to comment/uncomment selected lines 

•  Indent/unindent 
–  Ability to indent/unindent selected lines 

•  Auto saves – automatic back up to 
inputname.fulcrum.autosave. 
–  File exists only while there are unsaved document changes 

•  Features illustrated on following slides 
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Miscellaneous : Column Selection/Edit 
Formatting related text into aligned columns allows for faster recognition 
and column-wise text operations.  

•  Fulcrum provides column selection via ALT+MOUSE SELECTION. 

•  With column selection made, any edits are made to all columns for each 
row.  

–  E.g., Update all isotope weight percent values to have a decimal digit. 
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Miscellaneous : Go To Definition 
The ‘Go To Definition’ feature (available via right clicking an input 
component) is intended to facilitate the user in quickly navigating to the 
component being referencing. New users can discover input component 
relationships. Experienced users can have their navigation accelerated, 
especially in larger inputs. 

•  Referenced mixture identifier – goes to the mixture’s definition. 

•  Referenced Geometry unit identifiers (holes) – goes to the unit definition. 
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Miscellaneous : Math Evaluations 
Often engineering specifications require conversion to input specifications. 
Even if a calculator is readily available, a human component is required to 
enter the converted (e.g, inches to centimeters) value into the input. 
Fulcrum provides an inline math expression evaluator. 
•  Removes/mitigates typographical errors related to converted numeric input entry.  
•  Encourages documentation of engineering specifications that require conversion. 
•  Full complement of math functions available :  

–  +,-,*,/,^,sqrt, cos, sin, root, abs, min, max, avg, sum, mul, floor, ceil, exp, log, logn, log10, hyp, if, 
clamp, inrange, sign, deg2rad, tan, equal, acos, asin, atan, cosh, tanh, sec, csc, cot, sinh, round, 
roundn, d2g, g2d, r2d 

•  Evaluation occurs on highlighted text. 
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Miscellaneous : Comment Toggle 

Comment toggling allows users to quickly comment or uncomment pieces of input. 

•  Allows comment creation. 

•  Mitigates user needing to recall what a comment looks like. 

•  Assists in input development iterations. 

•  CMD+/ on OS X and CTRL+/ on Windows and Linux.  
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Miscellaneous : Input Indent/Unindent 
Hierarchical input (Sequence > Read Block > Component Record) can be depicted 
using levels of indentation. Input indent and unindent facilitates quick formatting to 
visually depict hierarchy.  
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Miscellaneous : File Autosaves 
Any file Fulcrum edits - currently only text files - are 
immediately backed up to a filename.fulcrum.autosave. In the 
scenario that Fulcrum or the application or computer crashes 
the autosave file will persist.  

•  Upon Fulcrum restart, when reloading the original file, 
Fulcrum will check for filename.fulcrum.autosave and load 
this instead, mitigating any lost progress. 

•  A save of the file will remove the autosave. 
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Input Editor : Future Features 
•  Enhanced cursor context presentation. 

–  Display input record information under cursor with labels. 
–  Linked help documentation – press F1 and get help section 

describing the input record under the cursor. 

•  Enhanced input component forms. 
–  Allows displaying input record/block under cursor in a visual form – 

allows seamless input text to form round-tripping without loss of input 
formatting or input [quality assurance] comments. 

•  Input Differences. 
–  Visually difference two inputs. 

•  Enhanced output review capability. 
–  Warning and error quick navigation. 
–  Upgraded HTML output. 
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Summary 
•  Fulcrum Input Editor Components 

•  Text Editor Settings 
–  Syntax colors and default editor behaviors 

•  Syntax Highlighting  
–  Input component color 

•  Document Quick Navigation 

•  Cursor Context 
–  Formal location in the input document 

•  Input Block Start and End 
Highlighting  

•  Input Autocompletion 
–  Creation and editing of input  

•  Input Validation 
–  Simple and complex 

•  Input Execution 
–  customizable 

•  Output File Viewing 

•  Miscellaneous Features 
–  Find/Replace 
–  Column select/edit 
–  Comment toggle 
–  Selection indent/unindent 
–  Inline math evaluations 

•  Future Features coming soon to a 
Fulcrum on your desktop 



44 Fulcrum User Interface 

Exercise 1 : Lady Godiva 
Create the Lady Godiva experiment using CSAS6.  
Problem definition : 

Lady Godiva consists of 17.482 cm diameter sphere. 

Run V7-252 multiregion cross section with vacuum right 
boundary condition, and 10000 particles per generation 
with 200 generations skipped. 

Isotope Atomic Number 
Density 

U-234 0.000491995 
U-235 0.0449996  
U-238 0.002498 
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Exercise 1 : Lady Godiva 

Purpose : 
1)  New Input creation. 

2)  Autocompletion of input. 

3)  Execution and output viewing.  
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Exercise 1 : Lady Godiva : Task 1 

Creation New document named InputEditorExercise1.inp 
•  File>New File… 

•  Specify InputEditorExercise1.inp. 

You should now have a blank input file. 
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Exercise 1 : Lady Godiva : Task 2 

Autocomplete a csas6 sequence. 
•  With cursor in text editor, select Edit>Autocomplete, or 

press CTRL+SPACE key combination. 

•  Select the csas6 – Criticality safety analysis using KENO-VI. 

•  Change ‘title-goes-here’ to ‘Lady godiva.’ 

•  Change ‘xslib-goes-here’ to ‘v7-252.’ 

You should now have an input file with minimum required input 
blocks. Notice the validation errors indicating what is needed. 
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Exercise 1 : Lady Godiva : Task 3 

Autocomplete 3 stdcomps with atomic density and 
temperature for the listed isotopes.  

•  With cursor in comps block, select Edit>Autocomplete, or 
press CTRL+SPACE key combination and select the 
stdcomp – basic + atomic density + temperature. 

•  Update the isotope and atomic density (aden)  
•  Repeat the above 2 steps for each isotope in the table. 

You should now have a complete  
composition block. Isotope Atomic Number 

Density 
U-234 0.000491995 
U-235 0.0449996  
U-238 0.002498 
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Exercise 1 : Lady Godiva : Task 4 

Autocomplete the cell block and 17.482 diameter spherical 
multiregion cell. 
•  With cursor below the comps block and above the geometry 

block, select Edit>Autocomplete, or press CTRL+SPACE 
key combination and select the cells. 

•  With cursor in the cells block, select Edit>Autocomplete, or 
press CTRL+SPACE key combination and select the 
multiregion - spherical. 

•  Update the multiregion zone input to reflect the proper 
sphere radius. 

You should now have an input with complete comp and cell 
data. The validation messages should indicate error about 
global unit’s missing media,hole, etc. 
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Exercise 1 : Lady Godiva : Task 5 

Autocomplete the sphere. 
•  With cursor below the global unit and above the unit 

boundary, select Edit>Autocomplete, or press CTRL
+SPACE key combination and select the sphere. 

•  Update the sphere radius to the appropriate value. 
You should now have an input with a sphere region specified 
but no media. 
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Exercise 1 : Lady Godiva : Task 6 

Autocomplete the media. 
•  With cursor below the sphere and above the unit boundary, 

select Edit>Autocomplete, or press CTRL+SPACE key 
combination and select the media. 

You should now have an input with a sphere region specified 
and media. Notice the media material and region definition 
vector was updated as the default values matched the 
generated material id from task 3 and 5. 

There should be no validation errors. 
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Exercise 1 : Lady Godiva : Task 7 

Execute the first input iteration. 
•  Click the Run button. 

•  Click the Messages panel. 

•  Note the k-eff value of ~1.0007 + or – 0.0016. 

At this point you should have a functioning input, that needs a 
parameter block. 
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Exercise 1 : Lady Godiva : Task 8 
Autocomplete the parameter block and run again. 
•  With cursor below the cells block and above the geometry block, select 

Edit>Autocomplete, or press CTRL+SPACE key combination and 
select the parameters. 

•  With cursor in the parameter block, select Edit>Autocomplete, or press 
CTRL+SPACE key combination and select the npg – no. per 
generation. Update to 10000. 

•  With cursor in the parameter block, select Edit>Autocomplete, or press 
CTRL+SPACE key combination and select the nsk – generations 
skipped. Update to 200. 

•  Click the Run button. 

•  Click the Messages panel. 

•  Note the k-eff value of ~0.9999 + or - 0.0044 
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Exercise 1 : Lady Godiva : Task 9 
Open the output. 
•  In the document Navigation panel right click the 

InputEditorExercise1.inp file. 

•  Mouse over Open associated files. 

•  Select the InputEditorExercise1.out file. 

•  Conduct a find on ‘best estimate.’  

•  Notice the expected value. 

Exercise complete. 
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Presentation Outline 
•  General Plot Overview 
•  Plot Controls 

•  AMPX Cross Section Data 

•  Covariance Data 

•  ORIGEN Isotope Concentration Data (F71) 

•  F71 Special Plot Controls (PlotOPUS) 

•  ORIGEN Gamma Data 

•  General Output Result Plots 
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General Plot Overview 
•  Interactive and configurable plot rendering 
•  Plot data table displays graph data. 

–  allows row and table copy to clipboard. 
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Plot Controls 
 Fulcrum plots consist of graph, bars, or color maps, which can be 
manipulated as follows. 

•  Select graph via left click in plot or legend. 
–  Remove selection via context menu ‘Remove selected 

•  Zooming is performed via the mouse scroll action. 
–  Zoom in by scrolling up. 
–  Zoom out by scrolling down. 

•  Reset to original via context menu Fit graphs. 

•  Panning is performed via a click and drag. 
–  Pan right by left clicking and dragging left. 
–  Pan up by left clicking and dragging down.’ 

•  Save Plot as  
–  PDF (includes scalable vector graphics SVG), 
–  PNG and JPG image format 
–  Interactive Scale Plot Format (SPF) 

•  Plot attributes (color, style, etc.) can be changed via context menu Plot options. 

•  Plot Legend can be drug to 9 cardinal positions via left-click and drag. 



59 Fulcrum User Interface 

Plot Controls : Plot Options   

•  Chart – Allows changing the plot title and title visibility. 
•  Legend – Allows changing the legend’s font and visibility. 

•  Axis – Allows changing axis visibility, label text, label text 
font, axis scale, axis range, axis grid, tick label font and tick 
text attributes (rotation, precision, etc.). 

•  Graphs – Allows changing graph name, line style, line color, 
line weight, scatter style, scatter size, pen style, adaptive 
sampling*, errors bars. 

•  Bars – Allows changing bar graph name. 

•  Color Map – Allows changing color map graph name and 
color gradient. 
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Plot Controls :  Plot Creation 
Plots can be created 
standalone or added to 
existing.  

•  Double left-click a plot to 
create a new plot. 

•  Alternatively, right click 
and select New plot. 

•  Add to preexisting plot via 
a right click and selecting 
Add graph to…. 
–  Add is only available for 

plots with matching axes. 
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AMPX Cross Section Data 
 AMPX Cross Section Data is available in 
multigroup (MG) and continuous-energy form 
and is located at ${SCALE}/data. Because the 
files do not have a unique extension, the user 
must load them specifically by type.  

•  Load MG XS data via File>Open multigroup 
library… 

•  Load CE XS data via File>Open continuous-
energy library... 

•  CE XS data are displayed hierarchically  
–  by Neutron or Photon, Isotope, Temperature (K), and 

Reaction. 

•  MG XS data are displayed hierarchically  
–  By Isotope, Neutron or Gamma, Reaction XS  

or transfer array.  
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Plot Exercise 1 
Description: 
Compare the 252 MG vs. CE U-235 Fission cross section at 
293K and produce a PDF of the 108 barn peak between 
0.1-10 eV. 

Intent: 

Familiarity with loading CE and MG libraries.   

Familiarity with plot controls (zoom and pan). 

Familiarity with combining plots. 

Familiarity with saving plots. 
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Plot Exercise 1 : Task 1 
1.  Load CE V7.1 ENDF library from the SCALE/data directory. 
2.  Find the U-235 Isotope at 293K. 

3.  Double click the 293 navigation item to load the reactions 
at that temperature. 

4.  Find the U-235 mt=18 fission 293 K xs entry. 

5.  Double click the entry to create a 2D plot. 

6.  Done. 
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Plot Exercise 1 : Task 2 
1.  Load 252 group MG library from the SCALE/data directory. 
2.  Find the U-235 Isotope Neutron Reaction XSecs entry. 

3.  Find U-235 mt=18 fission entry. 

4.  Right click the entry to obtain a popup context menu. 

5.  Click the Add to graph to… menu item. 

6.  Done. 
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Plot Exercise 1 : Task 3 
1.  Pan the plot to be centered at 1 eV. 

–  Left click and drag 

2.  Zoom the plot to the requested eV range. 
–  Scroll up zooms in. 

3.  Repeat steps 1 and 2 as needed to center plot about the 
~108 barn cross section peak near 1 eV. 

4.  Right click to obtain the plot context menu. 

5.  Select Save as>PDF and specify PlotExercise1.pdf. 

6.  Done 

Exercise complete. 
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Covariance Data 
 Covariance Data is available at SCALE/data. 
Because the files do not have a unique 
extension, the user must load them specifically by 
type.  

•  Correlation coefficient matrix color map plots 

•  Covariance matrix color map plots 

•  Isotope Reaction Standard Deviation by 
energy or group graph plots 



67 Fulcrum User Interface 

ORIGEN Isotope Concentration Data (F71) 
 
 
Origen concentration data contains results from depletion, decay, and activation 
calculations. The plot capabilities are centered about the expected Fulcrum interactive plot 
with the addition of a more familiar PlotOPUS style set of controls. 

•  Easy selection of state information to display. 

•  Easy display of nuclides or elements by id or category. 

•  Easily display different units (Decay, Mass, Number). 
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F71 Special Plot Controls (PlotOPUS) 
 •  Navigation allows selection of state information at a given time point. 

•  Element allows display of results by element instead of nuclide. 

•  SymNuc allows specifying nuclides or elements to include in the plot. 

•  Libtype allows display of nuclides or elements contained in the light elements, actinides, 
and fission product isotope sets. 

•  Nrank allows limiting the display of the top contributors. 

•  Time, Plot, and Sort Units allows changing the X and Y axis and the nuclides or 
elements displayed based on contribution. 
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ORIGEN Gamma Data 
 The master photon data library, located at SCALE/data/

origen_data/origen.rev##.mpdkxgam.data, provides both 
discrete and continuous energy gamma lines. 

•  Opened via File>Open 
ORIGEN gamma 
data… 
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General Output Result Plots 
 •  Keno k-effective By Generation. 
•  Keno Frequency Distributions. 

•  Keno Flux. 

•  Keno Final edit of fissions, absorptions, and leakage. 

•  MAVRIC batch convergence data for point detector and 
region tallies.   

•  MAVRIC response input and multigroup representation. 

•  Sampler histograms, histories, running averages, and scatter 
plots. 

•  Opus Plots (plt) 

•  And others… 
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Keno Result Plots 
•  Plot of average k-effective by generation run  
•  Plot of average k-effective by generations skipped  

•  Final edit of fissions, absorptions, and leakage  

•  Frequency distributions 

•  Shannon Entropy   

•  Flux plotting 
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Summary 

•  Plot Overview 
•  Interactive plot controls 

•  AMPX Cross Section Data 

•  Covariance Data 

•  ORIGEN Isotope Concentration Data (F71) 

•  F71 Special Plot Controls (PlotOPUS) 

•  ORIGEN Gamma Data 

•  General Output Result Plots 

•  Questions? 
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Presentation Outline 

•  Geometry Viewer Overview 
•  Activating the Geometry Viewer 

•  Viewer Controls 

•  Axis Views 

•  Render Modes 

•  Geometry Magnification 

•  View Origin 

•  Show View Origin 

•  View Origin Preserved Across 
View Plane (Top to Front, etc.) 

 

•  Geometry Error 
Presentation  

•  Miscellaneous Features 

•  Mesh Overlay Overview 

•  Mesh Overlay Supported 
Formats 

•  Mesh Overlay Controls 

•  Future Features  



75 Fulcrum User Interface 

Geometry Viewer Overview 
Geometry viewer uses ray tracing to present a perspective as 
close to the particle transport as possible to the user. 
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Geometry Viewer Overview 
•  Axis Views provide 2D axis-aligned geometry renderings. 

•  Available Meshes to Overlay allows combining geometry rendering with 
mesh-based results. 

•  Render Modes – toggle between different material, outline, and mesh 
overlay render modes. 

•  Show view origin – highlights exact point at center of view with crosshair. 

•  Position, Unit, and Mixture under Cursor – communicates geometry 
information under mouse cursor. 

•  View origin – displays and provides control of the origin of the view. 

•  Axis view plane slide controller – interactively manipulates the elevation 
of the view plane. 

•  Context Menu (via right click) – allows changing color and saving 
images. 
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Activating the Geometry Viewer 
Activating the geometry viewer can be accomplished via the 
Input Editor’s View…>View geometry button or the Document 
Navigation geometry 
item’s popup context  
menu. 

•  If multiple geometry 
input blocks exist in 
the document, a  
selection will be  
provided. 



78 Fulcrum User Interface 

Geometry Viewer Controls 
Geometry viewer controls facilitate manipulation of the 
geometry rendering. 

•  Axis (X,Y,Z) rendered. 
–  Top (X-Y) – view plane intersects Z axis. 
–  Front (X-Z) – view plane intersects the Y axis. 
–  Side (Y-Z) – view plane intersects the X axis. 

•  Elevation (axis intersection) of the view plane rendered. 

•  Type of rendering. 
–  material, outline, mesh, etc. 

•  View origin (point at center of view plane). 
•  Geometry Magnification. 
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Axis Views 
•  Axis views provide standard orthographic model projections 

of the top, front, and side of the geometry.     
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Axis Views : Elevation Control 
View plane elevation is controlled via a slide control on the 
right side of each geometry view.     

•  View plane elevation 
corresponds to view 
plane control – the 
higher the slider 
control, the higher the 
view plane. 
–  Top (X-Y) - raising the 

slider increases the Z 
intersect. 

–  Front (X-Z) – raising the 
slider increases the Y 
intersect. 

–  Side (Y-Z) – raising the 
slider increases the Z 
intersect. 
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Render Modes 

Render modes control the information 
displayed. 
•  Material displays only the materials/

mixtures. 
–  Can hide geometry region 

outlines that are the same 
material. 

•  Material + outline displays the 
material and the region outlines. 
–  Displays region outline in black. 
–  Useful for contrasting geometry 

regions. 

•  Outline displays only geometry region 
outlines. 
–  Displays region outline in material 

color. 
•  Overlay displays geometry region 

outline and mesh data results. 
•  Overlay + boundaries displays 

geometry region outline, mesh 
boundaries*, and mesh data results 
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Geometry Magnification (Zoom)  
Ray traced geometry rendering allows for significant 
magnification. 

•  Specific value typed by user. 

•  Incremented or decremented via zoom 
editor spinner controls. 

•  Visually specified via a user-drawn  
zoom reticle. 
–  Left click and drag down and to the right. 
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Geometry View Origin Display and Control 
Often when geometry errors are encountered, an X,Y,Z position is included in the error message. 
The ability to quickly navigate to this location and inspect the geometry is facilitated by the view 
origin control. 

•  Left click the View origin display to activate X,Y,Z entry. 

•  3 Modes of Origin input 
–  Single value : Updates the view plane elevation (axis intersect – same as slider control). 
–  Two values : Updates the view plane 2D origin (pans the image). 

•  Top (X-Y) – sets the X and Y coordinates of the origin. 
•  Front (X-Z) – sets the X and Z coordinates of the origin. 
•  Side (Y-Z) – sets the Y and Z coordinates of the origin. 

–  Three values : 
Updates the view plane 
elevation and the view  
plane 2D origin.  

•  Double Left click centers 
the view origin at the point 
clicked. 

•  Useful when combined with 
the Show View Origin.  
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Show View Origin 
With ray traced geometry rendering allowing significant 
magnification, it can be difficult to focus on a specific location. 
The Show view origin button was added to unambiguously 
display the location of the view’s origin. 

•  Very useful when debugging geometry at a given location. 
–  Enter the location via the view origin control. 
–  Show the view origin. 
–  Magnify as needed. 
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View Origin Preserved Across View Plane 
The geometry viewer is often used for geometry verification 
and debugging. Both typically involve known locations – X,Y,Z 
of lost particle, etc. 

•  View origin is preserved during view plane changes (Top to 
Front, etc.) 
–  Facilitates quickly identifying locations where initial view plane is 

epsilon (1e-15) off a tangent surface. 

•  Cloneable geometry viewer with subsequent view plane 
change allows quick visual comparison of location. 
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Geometry Errors : Undefined Space 
Undefined space lacks any geometry specification. This 
typically happens when a space is not accounted for with a 
material statement. 
•  Cursor information lacks mixture information. 

•  Undefined space is rendered with grey stripes. 
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Geometry Errors : Double-Defined Space 
Double-defined space has more than a single geometry 
specification for a give space. This typically happens when a 
space is not excluded appropriately. 
•  Cursor information lists multiple mixtures. 
•  Double-defined space is rendered using alternating striped mixture 

colors. 
•  NOTE : the tangent planes of adjacent regions can appear as double-defined 

space but are infinitely thin. 
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Mesh Overlay Overview 

•  Loading Mesh Data. 
–  Supported formats (see slide 89). 

•  Render Modes. 

•  Contours and color legend. 

•  Scale – Log and Linear. 

•  Range – File, Family, Dataset, 
 or Custom. 

•  Position, Mesh value, Mesh  
Voxel, Unit, and Mixture under  
Cursor. 

•  Context Menu. 

•  2D Plot creation. 
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Mesh Overlay : Loading Mesh Data 
With the available Meshes window open, a context menu is 
available via right click. This context menu will allow loading 
new, and removing or reloading existing mesh files. 

•  Right click in Available meshes to access Load mesh file 
dialog. Select the mesh to load.  

•  Most of SCALE’s major 
mesh formats are supported 
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Mesh Contours, Color Legend, and Scale 
•  Controls influenced by MAVRIC’s MeshView plot program. 
•  Allows changing contour count from 25 to 2 enhancing data 

contrast. 

•  Can improve print quality for black and white printouts. 

•  Linear and logarithmic scale data display. 
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Mesh Overlay : Data Ranges  
The overlaid dataset’s data range can be selected as the file, 
family, dataset or as custom user-specified. 
•  The file indicates the entire mesh 

file context. 
•  The family range provides context  

to a selected dataset. 
•  Custom allows down-selection. 
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Mesh Overlay : Integrated 2D Plot Creation  
Mesh data can be further investigated via the integrated 2D 
plot creation capability. 2D Plot creation is  
available via the Create plot popup context menu.  

•  Plot options include 
–  Independent axis 

•  Cartesian X,Y, and Z. 
•  Cylindrical Radial, Theta, 

and Z. 
•  Group when group-wise 

data is available. 
–  Plot using values or  

indices. 
–  When data is group-wise 

axis interval widths can 
optionally be divided 
linearly or logarithmically.  
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Geometry Viewer : Future Features 
•  3D Ray traced visualization.  

–  Material Transparency.  
–  Geometry Culling Surfaces (similar to Keno3D cutaways). 
–  Mesh Overlays. 

•  Geometry view to Input material definition quick view. 
–  Allows display of input that creates the material under the cursor. 
–  Allows display of isotopic number densities that compose the material 

under the cursor. 
•  Geometry view to Input region definition quick view. 

–  Allows display of input region/media statement that creates geometry 
under cursor. 

•  Visualize any unit on-demand with an optional nesting level. 
–  Allows investigating single geometry units with limited depth/

complexity.  
•  Enhanced input and geometry coupling. 

–  Display grid/cylinder geometry prior to job execution. 
–  Display detector/source locations prior to job execution.    
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Summary 

•  Geometry Viewer Overview 
•  Activating the Geometry Viewer 

•  Viewer Controls 

•  Axis Views 

•  Render Modes 

•  Geometry Magnification 

•  View Origin 

•  Show View Origin 

•  View Origin Preserved Across 
View Plane (Top to Front, etc.) 

 

•  Geometry Error 
Presentation  

•  Miscellaneous Features 

•  Mesh Overlay Overview 

•  Mesh Overlay Supported 
Formats 

•  Mesh Overlay Controls 

•  Future Features  

•  Questions? 


